Jump to content
  • 0

Assassin's creed IV Black Flag installer stuck at 0%


 Share

The last reply on this topic is older than 122 days. Please do not unnecessarily bump it. The most recent reply to this topic was posted 1429 days ago.

Question


  • Followers:  0
  • Content Count:  7
  • Content Per Day:  0.00
  • Reputation:   4
  • Status:  Offline
  • Last Seen:  

I am new to your site.and this repack(i.e-assassins creed iv) is my first download from your site.after successfully downloaded the game when i clicked the setup file it stuck at 0% and after 2 minutes setup automatically exit.please tell me how to fix this.

Btw i am using i am using windows 10 (64 bit) latest release,8gb ddr3 ram,i5 4th gen

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

  • Followers:  64
  • Content Count:  1,704
  • Content Per Day:  0.94
  • Reputation:   14,447
  • Status:  Offline
  • Last Seen:  
  • Device:  Windows

follow the instructions to successfully install the game:

  1. try to install in the main drive i.e C drive where usually operating system resides
  2. when installing, make sure you are not running any programs that may interfere with the setup resources
  3. start the setup with admin rights
  4. make sure you have cleared your cache before you start the installation
  5. make sure you have enough disk space and other resources not in use when you start the installation
Link to comment
Share on other sites

The last reply on this topic is older than 122 days. Please do not unnecessarily bump it. The most recent reply to this topic was posted 1429 days ago.

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines, Terms of Use, and Privacy Policy with it We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.